Welcome to aurora.com! Log in or Sign up to interact with the aurora community.

How to stay with 2 extruders in dual Z drivers mode?

Discussion in 'RUMBA' started by newb3d, May 22, 2015.

  1. newb3d

    newb3d New Member

    Joined:
    May 22, 2015
    Hello guys.

    Apologize for my bad English.

    Recently I got Rumba controller from Ebay for my first 3d printer Prusa I3. I flashed it with code found on http://reprap.org/wiki/RUMBA#RUMBA_Firmware_Pin_Configuration

    Next step I tried to use 1 extruder as second Z axis controller.

    CONFIGURATION_ADV.h
    #define Z_DUAL_STEPPER_DRIVERS



    During compilation I got message

    Arduino: 1.6.3 (Windows 7), "Arduino Mega or Mega 2560, ATmega2560 (Mega 2560)"

    In file included from Configuration_adv.h:547:0,
    from Configuration.h:821,
    from Marlin.h:22,
    from BlinkM.cpp:5:
    SanityCheck.h:75:8: error: #error EXTRUDERS must be 1 with Z_DUAL_STEPPER_DRIVERS.
    #error EXTRUDERS must be 1 with Z_DUAL_STEPPER_DRIVERS.

    Without any choice I changed number of EXTRUDERS to 1... but Rumba has native support for 3 extruder's any hints how to use 2 extruders with dual Z mode?

    Thank you in advance.
     
  2. newb3d

    newb3d New Member

    Joined:
    May 22, 2015
    Perhaps another firmware than marlin would do that?
     
  3. newb3d

    newb3d New Member

    Joined:
    May 22, 2015
    As suggested in another forum I went from Marlin to Repiter, easy, friendly web gui for firmware setting. Works with lots of motors can support dual XYZ lots of extruders and so on... just be careful with limit switch, by default only 1 direction open...
     

Share This Page