Welcome to aurora.com! Log in or Sign up to interact with the aurora community.

Marlin and Core XY feature

Discussion in 'RUMBA' started by EmmanuelG, Feb 27, 2013.

  1. EmmanuelG

    EmmanuelG New Member

    Joined:
    Feb 14, 2013
    Location:
    France
    As per http://forums.reprap.org/read.php?1,163243 after uncommenting the CoreXY line in the firmware I also set the stepper to be enabled all the time (especially for Z in my case)


    // Disables axis when it's not being used.
    #define DISABLE_X false
    #define DISABLE_Y false
    #define DISABLE_Z false
    #define DISABLE_E false // For all extruders


    But if the Z is ok, the X and Y seems to be released and thus the movement of the H-bot style XY is not made correctly if the other stepper is disabled (in diagonal instead of straight in X per example).

    I was wondering if there is something on the hardware side that could explain that (as my other test board, an AzteegX1, didn't had this problem)

    I also tried to uncomment the
    //default stepper release if idle
    #define DEFAULT_STEPPER_DEACTIVE_TIME 60
    and all the other things linked, but it was worse ^^' (and it worked with it on the other board)

    Both firmwares are in my github repo for eventual comparison
    https://github.com/EmmanuelG/FoldaRap2/tree/master/firmware
     

Share This Page