Welcome to aurora.com! Log in or Sign up to interact with the aurora community.

Which firmware works with the Full Graphic Smart Controller?

Discussion in 'RRD LCD Smart Controller' started by Charles Lowry, Jan 24, 2014.

  1. Charles Lowry

    Charles Lowry New Member

    Joined:
    May 26, 2013
    I am having many of the same problems as Pablo and I need to know what firmware worked so I can get this fixed.

    I have done everything mentioned here and elsewhere. Swapped EXP1 <-> EXP2, uncommented #define REPRAP_... etc. Nothing helps.
    I am now stuck with the Smart graphic controller flashing and beeping. Been at it for many hours and I'm stumped. It compiles well and uploads to the RUMBA board. Turn it on and it starts flashing and beeping. Press or turn the select knob and it stops. No backlight or display.
    I'm using a RUMBA board and the Full Graphic Smart Controller compiled with Arduino 1.0.5-r2.
    If you could post here what firmware version is known to work with the RUMBA and the Full Graphic Smart Controller that will probably help others along the way as well. I've got a feeling this problem will go on for a while. Who knows when the Arduino team will get this fixed!

    Thanks!
     
  2. Charles Lowry

    Charles Lowry New Member

    Joined:
    May 26, 2013
    Additionally, when I press or turn the knob it stops only momentarily, then it starts flashing and beeping again.
    I also have the board set to 80 in Arduino. I think the software setup is fine, the problem is in the firmware or somewhere else.

    Any help is enormously appreciated!
     
  3. Charles Lowry

    Charles Lowry New Member

    Joined:
    May 26, 2013
    RUMBA and Full Graphic Smart Controller not working

    Worked on this for a few days and realized there is a problem with the latest firmware and the Reprap Discount Full Graphic Smart Controller.

    When the graphic controller is enabled, it flashes and beeps and locks up the motherboard.

    Knowing how hard it is to explain the problem I went to the effort to make a video which is very convincing. In the video I start with no error, replicate the error, and undo the error.

    Unfortunately this isn't a cure for the error, and a fix needs to be found.

    Here is the video.

    I am using all the latest drivers and software.
    Arduino 1.0.5-r2
    Lastest Marlin firmware, adbf226... downloaded as a zip file.
    Motherboard == 80, #define Reprap_.. is un-commented.
    U8glib_arduino_v1.14.zip

    I am trying to get approved for a display at the San Fran Makerfaire and need to have my submission ready in 3 weeks. This isn't helping any.

    I hope someone has a suggestion to at least get the display working for the show.

    Charles.
     
  4. Charles Lowry

    Charles Lowry New Member

    Joined:
    May 26, 2013
    I got it working.

    Turns out the silk print on the motherboard for the graphics card display is BOTH backwards AND upside down!

    That is to say, on the RUMBA board the EXP 1 and EXP2 silkscreen is backwards, where EXP 1 < - > EXP2. ADDITIONALLY the pin#1 arrow for each cable is printed on the board at the top right telling us that the cable should be plugged in so the red wire is oriented toward the top right .... WHEN IN FACT the red arrow should be orientated to the bottom left!

    Amazing. This wild error is something not adequately disclosed anywhere I could find in the forums.
     
    Mike Fisher likes this.
  5. Mike Fisher

    Mike Fisher New Member

    Joined:
    Aug 22, 2016
    Thanks it helps a lot, i wars in trouble there too
     

Share This Page