Welcome to aurora.com! Log in or Sign up to interact with the aurora community.

working great, single 24v on Ramps 1.4 Universal Classic, Smart LCD controller, Endstops, MK2A Heatb

Discussion in 'Taurino Power' started by bob3, May 7, 2013.

  1. bob3

    bob3 New Member

    Mar 8, 2013
    hi all

    just wanted to pass on that I have the universal ramps 1.4 kit working on a single 24v 400 watt ps.

    this is a really nice kit.
    I see others might be having issues.
    I must have been lucky.
    no diode touching to get turino/ramps 1.4/heatbed mk2a/motor drivers working on 24.
    just plugged power in, downloaded marlin firmware, install repetierHost software in ubuntu 12.04 and it works.
    no issues seen so far.

    I don't know if I can post it all, but below are my build notes if it helps someone else:

    my build notes for ramps 1.4 kit on 24v

    Intsall arduino ide

    • for ubuntu 12.04, used the repository.
      • sudo apt-get install arduino
    • installs version 1.0.1
    Marlin download to Taurino

    • got marlin firmware from reprapdiscount US resalerlocation
    • set arduino ide for Mega 2560
    • verified Marlin.ino project compile, no errors reported.
    • connected usb to taurino, only usb.
    • downloaded Marlin.ino project to taurino.
      • complaint about no usb, arduino suggested another port which did work.
    • removed usb to taurino.
    • connected lcd header/ribbon cable to taurino.
    • connected usb to taurino
    • lcd and firmware worked.
    RepRapDiscount likes this.
  2. bob3

    bob3 New Member

    Mar 8, 2013
    Stepper Mechanical Setup and Test

    • apply heat sinks to stepper drivers
    • tip: to check stepper wire pairing:
      • with wires not connected to anything turn stepper shaft and note resistance.
      • connect two wires (red,green in my case using kysan 42bygh4803-dc)
      • note higher turning resistance, that's a pair.
    • connected stepper header to ramps1.4 board blue toward power headers.
    power supply 24v 16amps

    • 120v hot goes to "L", neutral goes to "N", earth ground goes to "ground symbol.
    • verify voltages out of +V / -V.
    • two of the "+V" goes to ramps 1.4 "+11a" and "+5a".
    • two of the "-V" goes to the ramps 1.4 "-11a" and "-5a".
    • NOTE:D1 on reprapdiscount universal taurino/ramps/lcd/ board does NOT need to be removed.
    • tested stepper; used taurino/lcd menu to auto-home.
    Configuration.h settings

    set baud rate

    • Repetier-Host v0.85c only works at 115200 baud
      • line 20,21 change to 115200 see Repetier-Host info below
      • must have j-head thermister hooked up for repetier-host to work/test servos, marlin software with shut down any movement if thermister falls below temp-min.
    current limit to j-head resister

    • Very important is (thanks to Triffid Hunter) to change your PID_MAX to 64 (and of course use PID control!).

    • reprap thermister guide.
    • set thermister type in Configuration.h starting at line 75.
      • our j-head is the Mk V-BV and uses the thermister 5 setting.
      • 20 lines prior are notes to sensor type value.
    • set max temp at line 96, to help on overheating.
      • note: mintemp line 88 is to check for broken thermisters and runaway maxtemps.
    End stops

    • endstops from reprapdiscount has led on board/switch so the endstop 'hit' led comes on.
      • need to hook up 5v/vcc for led to work. No vcc, swich/endstop still works.
    • upper right of ramps board.
    • signal,ground,power
    • blue,black,red
    • for mechanical, just need signal and ground.
    • check status of endstops with the gcode M119test using the auto home command from marlin/lcd.
    • Travel Limits measured in mm is at line 249, my build is 15inches x 15inches x 15inches
      • set x,y,z 400,400,380

    • direction of steppers is set via INVERT_X_DIR on line 233
      • E0 is the extruder.
    Don't Install hotend yet, do travel test/calibrate first.
  3. bob3

    bob3 New Member

    Mar 8, 2013
    Test 3d Printer

    • install printer interface software in ubuntu. (see below for installation steps)
    • set axis travel into the middle of each travel.
    • jog in each direction to confirm travel is correct.
    • extruder stepper can only be tested once hot end reaches 175 deg.
    • use remote cheap harbor freight temp probe to check temps.
    Calibrate travel

    • Steps Per Unit is at line 275
      • these are steps to get 1mm of travel.
      • DEFAULT_AXIS_STEPS_PER_UNIT {39.9979,44.3273,2289.844,785.0656}
        • steps per unit (x, y, z, e)
    • put dial indication in for the hotend.
    • tape ruler(s) onto bed.
    • send axis at least 100mm to sample travel.
    • calculate new steps per unit.
      • NewStepsPerUnit = SampleTravelDist / ActualTravelDist x OldStepsPerUnit
    • repeat as necessary.
    Mk V-BV j-head assemble

    • resister goes to ramps at D10. green led when on.
    • fan contorl goes to D9. red led when on.
      • red/vcc goes down near "+" on D9.
      • 120ohm resister spliced in as I only had 12v fan being run from 24v.
      • fan speed in repetierHost works for 24% to 100%.
    Heater Resistor

    • The heater resistor can be installed one of 3 ways:
    1. Put a little bit of muffler repair putty on the resistor and slide it into the hole. It can be cured by letting it set a couple hours before bringing the hot-end up to temperature.
    2. Slide the heater resistor in the hole. If it fits tightly, this will work. If there is any gap, between the resistor and brass, it may result in failure of the heater resistor.
    3. Wrap a thin strip of aluminum foil around the heater resistor and adjust it by gradually cutting it shorter until the resistor and file slide it into. Care must be taken to ensure that the proper amount of aluminum foil is used in order to take up any gap between the heater resistor and the brass.

    • Note: I'm using the current latest j-head Mk V-BV which has the tiny thermistor, it's about the size of a grain of rice or smaller.
    • Merlin frimware needs to be set for using Thermistor 5, as stated here.
    • Insulate the leads to the thermistor. This is usually accomplished one of two ways.
    1. Use Kapton tape as insulation by separating the leads and sandwiching the leads in-between two strips of Kapton tape.
    2. Use PTFE insulation and slide it over each lead.
    • Place the thermistor in its hole and secure it with Kapton tape.
    j-head assembly from Ultibots Support Team

    • Q: Are there any instructions for assembling the hot end?
    • A: We have searched the RepRap? community and the designer of the J-Head for an assembly guide without success. A good picture to reference is http://www.thingiverse.com/thing:39135 it shows the Ultibots method of assembly which is:
    1. Verify that the hollow set screw is snuggly tightened.
    2. Fill the heat resister hole with some muffler putty and insert the heat resister into the brass hole (the resister may need light sanding to fit). Apply more putty to other end and clean off excess. Fill the thermistor hole with some putty and insert thermistor into hole. Let J-Head dry for 8+ hours; really.
    3. Carefully cut and slide PTFE liners on resister and thermistor leads so 7mm of lead extends past the liner. Strip 7mm of insulation offJ-Head wire leads. Slide appropriate heat shrink over wire leads before soldering.
    4. Solder the lead wires to the resister and thermistor. Cover with heat shrink.
    5. Cover all solder joints with 1/4" heat shrink as shown.
    6. Once J-Head is attached to Micro Extruder body and motor is mounted, secure wiring to motor with a long zip tie (not shown).
    7. since we're using 24v:
    • Very important is (thanks to Triffid Hunter) to change your PID_MAX to 64 (and of course use PID control!).

  4. bob3

    bob3 New Member

    Mar 8, 2013

    pronterface in Ubuntu

    sudo apt-get install python python-serial python-wxgtk2.8 python-tk git-core

    There are also experimental packages for Ubuntu (maverick natty oneiric precise):
    sudo apt-add-repository ppa:richi-paraeasy/ppa
    sudo apt-get update
    sudo apt-get install pronterface

    • printer settings:
      • port: /dev/ttyACM0 or what is offered
      • baud rate: 115200 see configure.h settings above

    repetier in ubuntu also install slic3r

    • download tar from http://www.repetier.com/download/
      *unpack and run the:
      • configureFirst
    • notes
      • Make sure, your user has permission to connect to the serial port.
        • sudo usermod -a -G dialout yourUserName
      • You can try to install needed software automatically. You can do this any time later by running(I didn't need to do this):
    • installDependenciesDebian.
    to test repetier software I did the following:
    • in the installation dir run it by:
      • ./repetierHost
    • printer settings:
      • port: /dev/ttyACM0 or what is offered
      • baud rate: 115200 see configure.h settings above
      • stop bits: 1
      • parity: none
      • trasf prot: autodetect
      • recv cache size: 63
    • in printer menu, printer information one will see:
      • firmware: Marlin
      • if it states, firmware: unknown, check the configuration.h setting to 115200 baud.
      • also if one sees the status to the printer to be xx commands waiting, the baud rate is probable wrong or the port is not correct.
    • if repetier doesn't respond use this to kill it
      • pkill mono
  5. Fabricator

    Fabricator New Member

    Nov 16, 2013
    Is it a ramps 1.4 classic or a universal power?

    Because I have a Taurino Classic unfortunately. And for dimmensions over 200mm square side it is far easier to find 24V heater Bed than 12V. Taurino classic spec is under 20V and universal power is up to 35V.
    I haven't found any voltage spec about the Ramps that goes on it!!

    Do you think that I have to replace the ramps and the taurino? and wich version of rrd ramps 1.4 should fit?


    p.s. QU-BD are scam! I bought the wrong heater bed by mistake. I was stuck with it so I asked them if they would accept an exchange and I offered to pay for the trouble and shipping. They answered to my mail to say no problem, of course... and asked me for a tracking number shipping it back to them. And I did send it back... And after a month, no reply... A couple of email to any email address that I could find on their site. And tried to let them a chance to correct the situation, very politely. And... no answer for two weeks. And then my dispute time on paypal was over. Result, I paid for the item and for the shipping twice and I have to heater bed. They have the money plus the heater bed and they do not respond!! There is no phone number on their site and their business doesn't have a good reputation in arizona. Be careful.
  6. RepRapDiscount

    RepRapDiscount Administrator Staff Member

    Nov 13, 2012
    Thank you very much for the useful post, i will make make it sticky

Share This Page